Linux 5.18
[muen/linux.git] / drivers / net / ethernet / socionext / Kconfig
1 # SPDX-License-Identifier: GPL-2.0-only
2 config NET_VENDOR_SOCIONEXT
3         bool "Socionext ethernet drivers"
4         default y
5         help
6           Option to select ethernet drivers for Socionext platforms.
7
8           Note that the answer to this question doesn't directly affect the
9           kernel: saying N will just cause the configurator to skip all
10           the questions about Socionext devices. If you say Y, you will be asked
11           for your specific card in the following questions.
12
13 if NET_VENDOR_SOCIONEXT
14
15 config SNI_AVE
16         tristate "Socionext AVE ethernet support"
17         depends on (ARCH_UNIPHIER || COMPILE_TEST) && OF
18         depends on HAS_IOMEM
19         select MFD_SYSCON
20         select PHYLIB
21         help
22           Driver for gigabit ethernet MACs, called AVE, in the
23           Socionext UniPhier family.
24
25 config SNI_NETSEC
26         tristate "Socionext NETSEC ethernet support"
27         depends on (ARCH_SYNQUACER || COMPILE_TEST) && OF
28         select PHYLIB
29         select PAGE_POOL
30         select MII
31         help
32           Enable to add support for the SocioNext NetSec Gigabit Ethernet
33           controller + PHY, as found on the Synquacer SC2A11 SoC
34
35           To compile this driver as a module, choose M here: the module will be
36           called netsec.  If unsure, say N.
37
38 endif #NET_VENDOR_SOCIONEXT