Merge tag 'mvebu-dt64-4.19-2' of git://git.infradead.org/linux-mvebu into next/dt
authorOlof Johansson <olof@lixom.net>
Wed, 1 Aug 2018 02:07:19 +0000 (19:07 -0700)
committerOlof Johansson <olof@lixom.net>
Wed, 1 Aug 2018 02:07:19 +0000 (19:07 -0700)
mvebu dt64 for 4.19 (part 2)

Use more specific compatible for the Inside Secure SafeXcel on the
Armada 37xx and the Armada 7K/8K SoCs.

* tag 'mvebu-dt64-4.19-2' of git://git.infradead.org/linux-mvebu:
  arm64: dts: marvell: armada-37xx: update the crypto engine compatible
  arm64: dts: marvell: armada-cp110: update the crypto engine compatible

Signed-off-by: Olof Johansson <olof@lixom.net>
1  2 
arch/arm64/boot/dts/marvell/armada-cp110.dtsi

index 1c6ff8197a88b1f890fed5b592b9358986942145,42213f968f3f3ab28c45cf1b58d3c8c88e57e25d..840c8454d03e3e81770a718e8e6aa17f53298ec6
  
                CP110_LABEL(icu): interrupt-controller@1e0000 {
                        compatible = "marvell,cp110-icu";
 -                      reg = <0x1e0000 0x10>;
 +                      reg = <0x1e0000 0x440>;
                        #interrupt-cells = <3>;
                        interrupt-controller;
                        msi-parent = <&gicp>;
                };
  
                CP110_LABEL(crypto): crypto@800000 {
-                       compatible = "inside-secure,safexcel-eip197";
+                       compatible = "inside-secure,safexcel-eip197b";
                        reg = <0x800000 0x200000>;
                        interrupts = <ICU_GRP_NSR 87 IRQ_TYPE_LEVEL_HIGH>,
                                <ICU_GRP_NSR 88 IRQ_TYPE_LEVEL_HIGH>,