spi: xilinx: Add support for xlnx,axi-quad-spi-1.00.a